How can I paste source code with comments (#) without creating new blocks with each newline?

I am in the process of moving my notes from Apple Notes to logseq.

Many of them contain source code or config files, where lines are commented out with “#”. Of course this creates new blocks and tags or headers in logseq. I tried openening blocks with ’ or ```but as soon as I paste, the same happens.
Is there a way to avoid this?

Thank you!

Okay, I found why Command-Shift-V didn’t work, another application (Keyboard Maestro Engine) is intercepting it for it’S clipboard manager. As soon as I quit that, I can use the shortcut as intended
Is there a way to remap the shortcut in logseq?

Command-Shift-V should be customizable at Settings > Keymap > Block command editing > Paste text into one block at point

I will try this, thank you very much!