Missing text -please help

Hello, I have just lost the text of some pages. I see the pages, but they are completaly empty, all text and attached files are gone. I can open the page backup directory but I dont know how to use the files I found there. I would appreciate if somebody could help me out. I tried to reindex, but didn’t helped.

It happened after I tried to open Logseq on my ipad. I realized I dont have the text there, came back to my desktop app, thought it is a sync issue (I use iCloud), but I found the same empty pages.

EDIT: I was able to recover data from backup. I don’t understand what happened. I tried to reindex on the iPad, which was when I erased the body of my pages? But could Logseq load pages without its body? I am confused; it would be great to know how to avoid this (other than not using iCloud…). I rely on Logseq in almost everything during my work, but I have lost most of my confidence in the app.

Unfortunately, the issue is iCloud. When you leave a Logseq graph open on multiple devices at the same time and use iCloud to sync between them, you’ll for sure get sync conflicts. Luckily, Logseq creates backups in the /logseq/bak folder that’s within your graph folder.

The solution is to only have Logseq open on one device at the time, to use Git for syncing, or become a Logseq Sponsor so you get access to the alpha version of Logseq Sync.