Queries by property kept returning deleted property

I created a template to track flight related information, such as from, to, departure. I originally used the property landing, created a few flight info block with the template, then renamed (or deleted and added) the landing property to arrival and updated all existing flight info. However, when I tried to query like below, in the table view, the long gone property landing refused to go away. I’m pretty sure there’s no word of “landing” anywhere in my texts/templates.

Is there anyway I can get rid of this ghost property? I have seen this behavior before and remember having fixed it once by re-index or refresh. It didn’t work this time. Any help will be appreciated! TIA!

Actually figured it out after a bit more investigate. When I open the file with the query in a text editor, it looks like this

  • {{query (property arrival)}}
    query-table:: true
    query-sort-desc:: false
    query-properties:: [:landing :from :to :airline]

Once I deleted the :landing in the query-properties, this problem is resolved. However, this does seem like a bug where Logseq should be able to figure out by itself. Anyways, good to know!