Why are block property names also turned into pages?

Rather than using hashtags, I often prefer using a more semantic approach using block properties, e.g.

topic:: [[Programming/Java]]

Imagine my surprise when I figured out that topic has in fact also been turned into a page, and a pretty linked one. While I can somehow make sense of that (helps finding all the blocks where “topic” was used as a property), it leads to an inevitable pollution of my graph.

Is there a way to disable this auto-linking of property names (and possibly, get rid of the already created pages)?

1 Like

In config.edn

;; Enable all your properties to have corresponding pages
:property-pages/enabled? true

;; Properties to exclude from having property pages
;; E.g.:property-pages/excludelist #{:duration :author}
;; :property-pages/excludelist

You can either disable them all by setting the first option to false and then manually delete your existing ones or have an excludelist of properties where you don’t want a page.

5 Likes

@MagePrometheus thanks, that solved it! Any idea if a similar configuration could help remove those from the graph too? I still see them hanging in there.

I’m sorry I’ve stopped digging into logseq. There were too many dark corners, like creating pages for tags and creating pages for properties without me adding brackets that didn’t work how my mind felt was ‘the right way’. Everyone will like different things so there is no best option but for my peace and happiness I’m using Obsidian and it doesn’t hurt anymore. Take care.

1 Like

Why my logseq app have no this condition setting in config.edn?

;; Enable all your properties to have corresponding pages
:property-pages/enabled? true

;; Properties to exclude from having property pages
;; E.g.:property-pages/excludelist #{:duration :author}
;; :property-pages/excludelist

Sorry, I don’t know but you can just add it.

Is your config.edn blank/empty or are those the only settings missing?

From settings, I don’t see the config.edn any more since the last update but if you go into your graph’s folder and then into the logseq folder it’s there and can be edited with care. Always make a backup copy first.

As @MagePrometheus said: just add the lines to your config.edn (accessible via ... > Settings > Edit config.edn. So add them to the end, and leave the rest of the file as it is. Then click out of the block and refresh the graph. Alternatively, you can edit the config.edn file directly using a plain text editor.

2 Likes