Be able to adjust the width of content area

Reason:

  1. when my content line in my code block is a little long, it will need to scroll to the right.
  2. when i write a markdown format table, if the content line is a little long, it will cause a forced line break, as shown in the following(my screen size is 13.3 inches):

Came here for this :+1:. Would be nice.

Agreed - after a search I stumbled here - Iā€™d like to use more of the available space for tables. Also - the markdown justification capabilities :ā€”: and :ā€” and ā€”: do not work.

If you go to Settings > Edit custom.css and then paste this snippet, the tables are better:

.table-wrapper {
  width: 100% !important;
  max-width: 100% !important;
}

table td {
  min-width:100px;
  word-wrap:break-word;
}
6 Likes

I fixed it with this:

th {
  word-break: keep-all;
}

You can try using if you do not use wide mode with shortcut keys t w

:root {
  --ls-main-content-max-width: 80%;
}