Can’t download Logseq on my Mac

Ive been trying to download the desktop version on my Mac and it keeps saying I need the latest version. Ive checked all updates and I seem to be on the latest version on my Mac.
I have been able to download Logseq on my phone and IPad, but I do see some features aren’t on these views. I can’t use Plugins on these. I’d like to see how the Calendar works with the Todo lists

Im not sure what I need to do to be able to get it on the Mac?

Welcome to Logseq and the community @Melissa_Pienaar!

It’s not clear to me where you’re trying to download Logseq from and what error you’re exactly getting.

Are you downloading from In that case, it’s possible the site is downloading the wrong version. You can pick the correct version from our GitHub page: Release Desktop/Android APP 0.10.3 (Beta Testing) · logseq/logseq · GitHub

If you still keep getting an error, it’d help a lot if you could post a screenshot. If you’re not comfortable doing so in public, feel free to email

Thank you so much, Im hoping it will help my squirrel brain to be able to put information down and in one place that I can actually find later.

Ive taken a screenshot of the message Ive been getting on my Mac.
I tried to follow the links you provided but Im unsure which one I need to click on lols

What Mac are you trying to run Logseq on? As in, what processor and what version of macOS?

If you’re on a Mac with an Intel processor, install:

If you’re on a Mac with an M processor, install:

In both instances, make sure you’re running at least macOS 14.

Thank you so much, I have manage to download it on my Mac.

1 Like

Great! Thank you so much for letting me know.

I’m closing this topic as your report has been solved.