Cannot import large graph on new computer

Hi everyone,

When I try to import my graph on a new instance of Logseq on a new MacBook Pro (M3 Max 96 GB) the app immediately locks up and never finishes importing (I’ve left it in this state for an hour plus).

My graph is large (889 journal entries; 2582 pages), but is this a known limitation? Also, is there a way to see/generate a detailed log of what is failing on import?

In the meantime, how can I import journal entries and pages into a new graph?

Cheers!!

That’s one beefy computer :eyes: I don’t think a memory limit is the problem.

The text file shouldn’t be a problem, but maybe you have very large assets in the graph folder?

If you want, I can have a look at the error logs. Please email them to support@logseq.com.

There are two logs that are useful in this: the console log and the main.log file.

Here are instructions on how to export console logs (it’s written by Figma but Logseq works the same):

This is where you can find the main.log:

  • Windows: C:\Users\USER_NAME\AppData\Roaming\Logseq\logs\main.log
  • macOS: ~/Library/Logs/Logseq/main.log
  • Linux: ~/.config/logseq/logs/main.log

Please note that I’ll be able to see your file names, but NOT any actual file contents.

2 Likes

@Ramses, I tried one more time to import before getting those log files and it imported. Haha!

BUT! I’m getting these errors as it imports and some pages are coming up blank even though the Markdown files on disk have contents:

Should I still send you the log files to inspect?

PS: I should have noted that my graph is stored on OneDrive…

It seems like Logseq is getting confused because of the spaces in the file names.

I advice you fix the file names in ... > Settings > Advanced > Filename format (in Logseq, of course). After that, do a re-index (the option is in the left sidebar when you click your graph name:)

reindex-option

2 Likes

When I check the Filename format it says Well done! No further action is required but there is no toggle/option:

When I check my filesystem after re-indexing, the filenames have not been updated. :man_shrugging: and yet in the config.edn I have this setting:

 :file/name-format :triple-lowbar

Which setting would remove spaces/whitespace since that is likely cause of the problems. Any ideas for next steps?