Can't "undo" after deletion of node?

If I delete a block by mistake, undo doesn’t allow me to get it back. Am I doing something wrong?

  • How do you delete it?
  • How do you undo?
  • What do you mean by “node”?

I highlighted a block and hit delete.

I click edit → Undo

A node is a bullet point and all the info attached to it.

  • Where do you find Edit?
  • Have you tried with a shortcut (e.g. Ctrl + z)?
  • Does Undo work for other things?
  • You are into Logseq for a year now:
    • Was Undo working before?
    • When did this behavior begin?
      • Do you have any other device to compare the behavior with?
  • What platform do you run Logseq on?
  • Which version of Logseq do you use?
  • Have you installed any plugins?

When the app is open on a Mac, in the upper left tool bar:

Logseq, File, Edit, View, Window Help

The Undo has never worked for me when a node has been deleted. I thought maybe it was just a place holder while still in beta and it hadn’t been gotten to yet. It does work on a line if I need to delete a character or something, but the cursor never moves to what was adjust, it just randomly moves to other lines and nodes and freaks me out a bit: I’m worried it’s going to undo something I don’t want undone.

I don’t have any other devices to compare it to since iOS app doesn’t have that option that I can see.

macOS Sonoma

Logseq 0.9.19

Plugins installed: goto-today, omnivore, raindrop, open-calendar, readwise, tags.

  • Have you tried undoing with Command(⌘) + Z ?

Yeah, that’s the dangerous one. That deletes entire lines, kind of just guessing how much it wants me to delete. It’s unnerving when I’m dealing with important notes. Using the edit → undo technique will delete single characters at a time.

That’s the issue. To get back the deleted node, try Command(⌘) + Z .

Well that’s really annoying since Command+z is supposed to be a shortcut, not a replacement for the undo in the menu.

Edit: But thank you! :+1: