Config.edn: `:favorites` - invalid type

Right after I upgraded Logseq to 0.8.17, whenever I save the config.edn file, an error pops up with below message and updates to queries in config.edn doesn’t take effect.
The file mentioned in the error message doesn’t exist on disk.

The file '/Users/<username>/Library/Mobile Documents/iCloud~com~logseq~logseq/Documents/logseq/config.edn' has the following errors:
:favorites - invalid type
1 Like

in 0.8.17 Logseq introduced validating graphs’ config.edn, so there are likely to be some warnings as we find out what users actually have.

To solve this issue;

  1. Navigate to Settings ⇾ from the general tab; click on Edit config.edn
  2. Locate the line containing :favorites
  3. replace the parentheses with brackets (...)[...]

If the solution of bader doesn’t work, it might trigger a bug of 0.8.17 which fixed in: fix: don't store broken config in DB by tiensonqin · Pull Request #8578 · logseq/logseq · GitHub

For current 0.8.17 users, you may have to clear cache manually to fix up


Thanks for sharing this, Junyi!
The 1st answer solved my problem so I didn’t try the solution you proposed.
Just want to let you know why I didn’t accept your answer as the solution.

1 Like

Thanks, I had the exact same issue!

1 Like

Could you open the config.edn and check the :favorites section?

I tried all of the suggestions starting with changing the brackets. When none of them worked, I checked that file again. I don’t know why, but Logseq refused to save my changes to config.edn, but it didn’t tell me that.

Once I edited config.edn with a separate program (VS Code in my case), the error was fixed.