Daily journal template not being used

I have a page journal-template that I would like to use as a template for my daily journal pages. The file is in the pages directory, named journal-template.md.

In my config.edn I have the following:

:default-templates {
	:journals "journal-template"}
}

But the template is not being used. What am I doing wrong?

1 Like

According to Templates, a template needs to have a template tag to be used as a template: Add template:: journal-template directly under your template’s title (the page name and the template name don’t have to be the same, Logseq only looks for the template entry).

Thanks for the information. I added that, but the template still didn’t get used.

1 Like

+1 after set it to template still won`t work

2 Likes

I followed How to Set Up an Automated Daily Template in Logseq but the journal did not update with the template. I also made sure I did not have today’s .md file for today created.

To check if things are setup correctly:

1. Test if the template is configured correctly

Run the template (anywhere): type the slash-command /templates, a list of templates should show up, choose your daily template. Press enter. It should run.

If not, your template is wrong. It should look something like this:

- ## Daily note
  template:: daily
  template-including-parent:: false
	- up:: placeholder
	- **A quote to think about**:
		- {{renderer :interstitial, random, "quote" }}
	- **Note self**:
		- {{renderer :interstitial, yesterday, "NTNDS" }}
	- ## End of day checklist 📝
		- TODO Write ntnds here:
			- Don't forget to write some encouraging words to your tomorrows self [[ntnds]]
		- TODO Today I learned
	- ## Planning
		- TODO vitamins
		- {{renderer :unfinishedBusiness}}
		- TODO What is todays _frog_?
	- ## Journal
		- **9:00** [[BHighlights]]

(This is a literal copy of my daily template)

If it does run “by hand”, then:

2. Make sure your ?/logseq/config.edn is correct:

 ;; When creating the new journal page, the app will use your template if there is one.
 ;; You only need to input your template name here.
 :default-templates
 {:journals "daily"}

That’s it, this should work.

The template is working cause I tried using it manually and it worked. I tried your template as well and double triple checked everything but still it’s not working unfortunately. It’s not the end of the world I can quickly do it manually daily only takes an extra seconds

What do you have in config.edn? because that’s where the problem must be, then.

I have been discussing this issue on github aswell. There is my config.edn there

I have experienced a similar issue. The application must be open throughout the night as you crossover into the next day for the template to work. Another hacky approach is to delete the current daily page, and once the page is recreated, the template will be added.

Have a similar issue on my end. I have 2 graphs setup. The first one is where I first wrote my template. logseq can recognize and apply the template just fine, but it doesn’t get applied to the new journal note at midnight. The second graph I have opened simultaneously with the first graph and has the same template settings. At midnight, only the second graph has the template applied to the new journal note. Not sure if this situation is similar for others here.

I am having this same issue. Tried all the suggestions mentioned. On logseq 0.6.6 desktop Windows.

1 Like

I think it is broken on the latest

1 Like

Broken here +1. On version 0.6.7 MacOS.

1 Like

Yep - I have raised this as an issue, and hopefully it will be fixed on the next version.

2 Likes

Yep, tried all the solutions.
Daily Journal Pages not applying the default template setting in the config.cdn.
So this is surely not working.
Only way to have it work is to delete the journal page for the day & create a new one… Then the default template is being applied.

For me it started working again with the 0.6.8 version released earlier this week.

2 Likes