Date formatting not changing

For a while, I’d been able to use the date format, “EEEE, MM/dd/yyyy”. Recently however, (hmm…after an unintended “clear cache”?) I am unable to change the date format from “MM do, yyyy” after selecting my preference in the editor settings and re-indexing.

What’s going on here? Is there a straightforward solution?

Thanks for help in advance!