Deactivate automatic numeration

When a block starts with

  1. text…
    Then Logseq automatically inserts a new line with a “2.” after pressing Enter.

That way the whole numeration will be in one bullet/block, at least that’s how Logseq wants it.

I want to have all numbers in single bullet points. Thus, the automatic behavior to keep everything under one bullet is unwanted.

Is there a way to deactivate it?


This is caused by Do What I Mean (DWIM). To disable it, add the following to your config.edn file:

   :admonition&src?  false
   :markup?          false
   :block-ref?       true
   :page-ref?        true
   :properties?      false
   :list?            false

Insert it before the last } and play around with true / false to suit your need


Amazing! Thank you! It worked.

1 Like