Default template for Journal

Hi. Just wonder is it possible for me to create a template so that every new day when I open my Journal, I will have a default template on it. The template that I planned to have is as follow:

  • Todo
  • Idea
  • Challenges for the day


Create your daily template as you would any other template, then visit your config.edn file via the Settings menu to see where to put it. There’s an explanatory note there.


@blork . Thanks for your input. Well, this is what I see when I open the “config.edn”. Honestly, I am not even sure how to get started with a blank page. Anymore advice on this please?

That’s definitely a bug. Try deleting this file

Yeah, definitely a bug. My config file is located at Documents/GraphName/logseq/config.edn - the switching slashes (/ vs \) concerns/confuses me, and I’ve never seen config be its own folder - should just be the file in the logseq folder (no . in my experience).

Hope Sawney’s suggestion works. Definitely report back.

May I know if I have input the “template” in the config.edn file. Now I go back to my journal page, how can I “reload” today’s journal page so that I can see whether I have done it correctly or not. I don’t want to wait until the next day just to test my template.

Just navigate to the daily kite page through search and then click the three dots on the top right and click dlete page.

1 Like

thanks for this answer – just what I was looking for – works!


I created a template for my journal pages and it works, but all the headings are indented one level down because of course the template is a block. How do I get my journal template to be the entire page, and put the headings that I have in the template un-indented?

this is the template
Screen Shot 2022-10-24 at 6.21.34 AM

this is the result on my journal page for today
Screen Shot 2022-10-24 at 6.21.27 AM

Said another way, is there a way to make a template for a page, as opposed to a block?

I’ve written this step-by-step guide for the Logseq blog. I hope it answers your question:

1 Like

I read your post, but the result is the same – all the headings in the template block end up indented when the template is activated.

I figured it out – I need to include template-including-parent:: false in the properties, like this
Screen Shot 2022-10-24 at 5.02.37 PM


@Ramses . Thanks for your effort in the writeup. I was really tied up with works and not able to come here and look for any updates.
FYI. I have tried out what you mentioned, but somehow my journal page will “jam” up.
This is the “Journal Template” that I created:

This is the edn file that I configured:

And when I go to journal page, refresh it or even totally close Logseq and restart Logseq, the journal page will “jam” up. Right click, left click all not working. I cannot do any edit and I cannot delete that page also. BUT… I can delete and edit other journal page.

Any idea what could be wrong here?

It seems quite tiring to learn how to use logseq.

My thought is it’s because you have template-including-parent:: false on a template block with no children. That property/setting is for when you want to write a template in which the parent block consists of information that is only useful where the template is being defined and that you don’t want to see when the template is being used.

Bowen’s example is a good one; you can see the parent block exists only to set the template:: name and the parent exclusion, while the child blocks contain all the content (and would thus appear as top-level blocks because the parent is excluded).

Your template is only one block deep—it is the parent, but childless, so it malfunctions because it doesn’t know how to output itself while also hiding itself.

Only use template-including-parent:: false when your template content is the child or children of some kind of header block. Removing that property should solve your problem. So would moving To-do::, tags::, etc. to a child block.


Your answer is in this reply by @blork (thanks blork!)

Personally, I would put the properties in their own block underneath the parent block. I have the same setup:

@Ramses and @blork .
Really appreciate you guys are trying your very best to help me. I really appreciate that.
Let me describe to you guys what I have done so far and what I saw and experienced.

  • This is what I have in config.edn:
  • This is what I have in my template file:

    Please kindly pay attention to the “todo::”. When I mouse click at that row this “todo::” will appear. If I click somewhere else, that statement will disappeared as shown below:
  • Regardless whether I set “template-including-parent” to true or false; regardless whether I have the topic “Journal Template” at the very top level or not. The template just will NOT appear in my journal page even though I use CTRL-R to refresh or even reinstalled the whole Logseq app. My two journal page will freeze up (Oct 30th and Oct 28th).
    left click on the “click here to edit” totally no response. Right click on the topic “Oct 30th” and right click on “click here to edit” never provide any menu as well.
    For other dates of Journal no problem. I can get a menu like this when I right click as shown below:
  • Now I try to disable all the theme, but I cannot find any uninstall button for me to uninstall all the themes. Worse still, when I click on the Cobra Theme that I have already installed, all I got is:
  • Even if I remove the template name from the config.edn file as shown below:

    My journal page for Oct 30th and Oct 28th still cannot work normally.
1 Like

After I change the config.edn file back to default as shown below. Now my journal page for Oct 31st 2022 can be edited.

However, the Oct 30th and Oct 28th are still not editable.


1 Like

What version of Logseq are you on @Rick_Dee, and what operating system? Because not being able to edit a block is very strange.

@Ramses , thanks for your reply. Here is my OS:
This is my Logseq version:
Ok… somehow today got Good News! The Journal Template seems to be working, but interesting thing is I already removed the template from the config.edn file before the date cross over to Nov 1st 2022.

This is how my journal template looks like:
This is the design page itself:
However, Oct 30th and Oct 28th journal page still stuck as shown below:
Whatever happened here is really bizarre.