Double brackets become double parentheses


Since this morning I experience a curious behavior under windows (I don’t have the problem under linux). When I type double brackets quickly to insert the reference to a page, it turns into a double parenthesis.
Instead of having this [[]] I get this (())]]
I tried to deactivate all the plugins but it doesn’t change anything…
This is very very annoying. Do you have any idea where this comes from?

I just tried this on Windows 11 and V0.5.7 (pre-release) and I am struggling to recreate, now matter how quickly I type [[. What app version are you on? I am sure you already did, but did restarting help?


Thanks for reply. I have 0.5.6 version on windows 10 enterprise.
This problem appears only in logseq so I eliminate the problem of shortcuts from windows…

Just tried with 0.5.7 version… same problem

I am afraid I am not sure what might be causing this - are you on the Discord? Might be worth posting there to see if anyone also experiences this - if not I am happy to post and relay the messages back on here

Thank you. I’m not on discord and I’d like a relay if possible.
I remain available here to provide clarification if needed.

Just posted - will report back any comments.

1 Like

Thanks you Ed_Nico :+1:

Same problem here…


How interesting - do you have a language keyboard activate or English? Not that this is the solution, but just trying to pin in down so that the Devs have a bit more insight of where to look

I use a keyboard with the bépo layout optimized for French but I don’t think that’s where it comes from. I don’t have the problem under linux with the same keyboard layout.

To insert a bracket I do Alt-Gr + 4

I have the same problem since the 0.5.6 update. I use the default AZERTY layout (Altgr + 5 to insert square brackets)


I have report your problem too on discord.

I have the same problem, with french azerty keyboard; windows 10.

1 Like

There is now a github issue. Feel free to add your use case and description :wink:

same problem on french keyboard,
if you type your first square bracket, type SHIFT, then type your second [ , it works !
so :

  1. [
  2. SHIFT
  3. [

not ideal but…

1 Like

Yep, got the same problem on french keyboard too.