Feature Request - Don't show children of linked reference in linked references section

In the Linked References section, Logseq shows the linked reference and its absolute children. But if you have many large paragraphs as the absolute children of “linked reference”, the Linked References section becomes meaningless as it becomes too crowded.

Roam doesn’t do this, they only show the actual “linked reference” in the Linked References section. I see more value in that behavior.

Adding screenshots to show what I mean.

Logseq

Roam


I find the way Roam does this way more useful.

Logseq is already collapsing the blocks that are not the direct children. I think it should be easy to collapse the direct children as well.

Other thing that really bugs me is the fact that linked reference is actually a linked block reference, because only appears extra information when they’re nested as children.
We can’t have access to the siblings blocks on the page more directly.
Or we hover over to the page toggle for preview or we click to enter in the page.

I think would be nice to have options for those either.

I understand what you are getting at and can understand the request from your point of view. I myself find the display of the children absolutely necessary. A pure listing of the link references would be much more uncomfortable because then I would have to constantly open the blocks/pages for the context/details.

I don’t mean to say that your feature request is unfounded, but only try to point out that there are also situations / ways of working where the current behaviour is very helpful.

I would NOT want to not show the children at all but showing them collapsed would be fine for me.

1 Like

I like the obsidians approach
image

Something similar would be awesome.

1 Like

Make the following change in your config.edn file :ref/default-open-blocks-level 1.

Results:


3 Likes

It didnt work here.

I got it to work.

As @Nick_Martin says, you need to set that config but you need to set it to 0, not 1 to match the Roam example I show in the first post.

Then after you make the change, restart Logseq and click on Re-index. It should work after that.

Screenshot 2021-09-07 at 6.47.24 PM

1 Like