Graph no longer loading after update to 0.6.8

I may need some help here. I downloaded the latest built (0.6.8) for my iMac (M1) and when I started the app, it got stuck in a loading loop. Looking at the console, there is a series of errors: "Uncaught (in promise) Error: [deferred timeout] async call #5, #1, #3 (successively). I think something may have been corrupted in my graph, as the iPad app, referencing the same iCloud location, now also hangs when loading. When I put back the previous version on my iMac, the same happens. I am not too worried about losing my data - I keep daily backups on Github, as well as an automatic local copy using Hazel - but I would like to know what the best way is to clean up this issue. Is there a way to prevent plugins from being loaded, for instance? Or are there working/temp files I can delete?

Can you paste the full errors?
Also, what plugins are you using?

Here is a screenshot of the console:

I have a suspicion it’s the wordcount plugin, as that’s the last one shown loading. It worked yesterday but not this morning. Is there a way to block plugins from loading?

By the way: my graph works again on the iPad.

You can go to ~/.logseq/plugins and delete some plugins there.
Can you expand the little triangle on the left? Usually, it’ll display more details on the error.

When I expand, all it adds is a line like this: (anonymous) @ index.01e3aa35.js:52
Not too informative.

Fascinating. I deleted all plugins. Restarted the app (first tried 0.6.8 then 0.6.7) - both hang while “Loading” - looking in the console, there are no errors at all. Nothing seems to be happening. I’m a little bit stumped by this. The iPad app is working fine at the moment but on the iMac - completely stuck.

Try deleting the cache directory for Logseq (make sure you noted or remember your graphs’ corresponding folders):

rm -rf ~/Library/Application\ Support/Logseq

So far, so good! Deleting the cache directory got things working again. I’m now running 0.6.8. All pages seem to load. Surprisingly, since I deleted all plugins from the plugin directory, some plugins found their way back in. I will now restore the plugin directory and see if that brings the whole thing down again.

But at least I’m up and running again. Thanks for the help @tienson - this could have been a painful experience but you have saved the day!

1 Like

Glad to know it works for you!

I deleted cache on my Mac and iPad, but the iOS versions are still not updating. This sucks.
Any other solutions? I really don’t want to remove all my plugins only to find out that doesn’t help either.