How can I hide the clock-time column in tables?

I have little use for it. Sometimes I press TODO instead of checking off the task by mistake so that’s probably why the column shows up at all sometimes. When it does I see total time but the column appears blank, by the way, but that’s a different issue. I just want to not have it show up in the table.

You can configure which columns are shown by clicking the little setting icon:

As an example, I don’t have the clock column in here though.

Addendum: actually you’ll not see the column itself in the list. However changing the settings will make it go away. So just remove any column and add it back in and the clock column should be gone.
(Just ran into this myself today lol)

1 Like

Indeed, only when you hide a property does it go away!

So all simple queries you want to see in table view have to go through the same process if they contain any blocks with clock time? So odd. Probably not a bug but this does seem like an opportunity for a redesign. I haven´t used clocked time yet but, if I did, having a column with all the individual clocked times (and total at the top) that you can turn off like other properties would be useful and less confusing, even if it´s not a property per se.


Yes indeed.
The clock column seems bugged as of quite a few versions. It used to show those individual times too.

1 Like