I cannot get quick capture options to work

I’m trying to modify the :quick-capture-options setting in config.edn.

I tried to follow the nominal directions in the comments:

;; Quick capture options.
 ;; - insert-today?   Insert the capture at the end of today\'s journal page (boolean).
 ;; - redirect-page?  Redirect to the quick capture page after capturing (boolean).
 ;; - default-page    The default page to capture to if insert-today? is false (string).
 ;; :quick-capture-options
 ;; {:insert-today? true           ;; Default value: true
 ;;  :redirect-page? false          ;; Default value: false
 ;;  :default-page "quick capture"} ;; Default page: "quick capture"
 {:insert-today? false
  :redirect-page? true
  :default-page "quick capture"}

After restarting logseq, it stil appends the capture at the end of the daily journal, and nothing is written to quick capture.md.

What platform are you on?
I’ve been having some issues with quick capture myself…
I’ve run into the following:

  • on Android: seems to work as intended through the share option
  • on iPad: seems to append to home page (for me this is not the journal), regardless of settings
  • on PC: I had some issues with the browser extension sending the capture to page “undefined”. Which… I don’t even know :sweat_smile:

Oh I remember!
On PC I had to adjust the settings of the browser extension for it to work!

In particular, I’d like this to work on IOS; I use both an iPhone and an iPad. I also use a Mac, and definitely switching the configuration for the extension works. But mobile grabs are just not working how I want.

I’m just doing a workaround for now by dumping them to Drafts.app, then when I’m back at my desk, I can reopen the link and save it where I want in logseq.

I’d prefer to not have to come back, although it has the added benefit of giving me a second chance to say “is this really worth saving?” :wink:

I trhink it is interesting about how the IOS save appends to whatever the home page is, not just “TODAY”. That might be a clue for someone?

Thanks, so much, @Siferiax ! Great to know it isn’t just me not understanding something!

1 Like