Image rendering issue Obsidian / Logseq (already tried some of the hints in this forum)

Setup: Obsidian and Logseq connected via a shared directory in Cloud.
Works like a charm - except one issue

Any help is greatly appreciated

What I’m trying to do

Try to use Obsidian and Logseq in parallel.
There is an issue with rendering.

Images that are pasted into Obsidian DO NOT show up in Logseq.
However, images pasted into Logseq DO show up in Obsidian.

(See screenshots)

Any help is greatly appreciated.

Things I have tried

I deactivated [[Wikilinks]] on Obsidian as suggested but that does not work.

Logseq cannot handle spaces in filenames.
When you remove the spaces from the filename and in the link remove the %20 (a space) it should render.

Hello Siferiax,

yep that works (with heavily manual process)
Do you know how I teach Obsidian to NOT use “Pasted image xyz” BUT instead use “imagexyz” (i.e. determining the prefix for assets)?

I’m not familiar (enough) with obsidian unfortunately.