Journal's yesterday "migrated" to today

Good morning,

I use Logseq (last version) with two machines, Windows and Linux with a personal cloud (owncloud) for syncing.

When booting on Windows, yesterday’s journal note has been “migrated” to today’s note. Now 2023-04-23 Sunday is empty and all the information appears at “2023-04-24 Monday” (??).

I’m unable to find (bak/.recycle) any 2023-04-23 file on my disk.

So, information has not been lost, but it’s not on correct day.


Moved to Logseq Sync, and the problem continues.
Every morning I see how when Logseq opens, all contents from “last journal note” is moved to the new day. So the previous day is emptied and all the information is copied to the new day…
I’ve disabled the calendar*, agenda and “block moving” plugins, but seems like that’s not the problem.
Hope to be able to save it in a video.


Just solved with this two steps:

  • Created a new vault with main folders, i.e data: journals, assets, notes.
  • Removed logseq from my computer and manually removed all “.logseq” folders on disk.
  • Installed logseq again.
    All of this on my Windows and Linux (ubuntu) machines.

I also have my graph in a git repo and have encountered this bug: the entire last day’s journal entry (all content) or from an older day (if there are blank, skipped days) will move to today’s date.

Upgrading Logseq versions to 0.9.8 hasn’t fixed it, so I will try recreating the graph.


Try to make all “new”, hope it solves the problem.
Since I had this problems and perform all this steps all is working ok.

Good luck!.

I found my issue; I installed the DailyTODO plugin, which was doing it’s job! I had recently installed it, but didn’t realize exactly how it worked.