Keyboard lag while typing

I am facing a noticeable keyboard lag on my mac after upgrading to 0.5.9 version. Is there a way to troubleshoot?

The app has become slower and slower. I type and wait for 3-5 seconds before it shows up in the editor. I have around 3000 notes but the deterioration in performance is really a concern for me.

that is certainly in the realm of “unusable” :confused: Unfortunately Logseq has a performance issue with large pages right now and although nothing can be done about that until the devs improve the performance, there are ways to work around that.

For example if the page has multiple sections, split these sections into pages and use namespace to connect them.

For if it’s a large page, when editing zooming in that section.

@cannibalox had good tips for these:

Logseq performance has improved quite a bit since then but it’s still a pain point :’(

1 Like

Thanks for sharing your thoughts. It’s not just large pages for me, but even the daily journal page is giving grief. I reinstalled the desktop app and it slowed down again. I’m now using Obsidian as it’s impossible for me to continue with Logseq. There is a world of difference in responsiveness!

I transitioned to Logseq because of the outliner mode which is my preference. But with a laggy editor, it’s a deal breaker for me.

I’m not sure how soon the issue will be fixed but perhaps Logseq is not for me at this time :unamused:

Try clicking the refresh button underneath the database switcher.

outliner mode which is my preference

Obsidian has some outline plugins that allows you to outline really well.

Obsidian performance is second to none. But now I know Logseq PDF integration I can’t live without it (I dig its area highlight and that after I’m done highlighting a chapter, when I go back I can easily add more highlights without having to worry about extracting highlights etc. and etc. Obsidian workflows for PDFs seem very complicated for me :(. Logseq PDF annotation works well enough that I’m putting up with the sluggish performance. But I do have serious concerns since I already see performance degradation at around chapter 4 of the textbook for my course, and I still have 20 more chapters to go :slight_smile: and it’s only 1 in several textbook I’ll read this semester. It does worry me quite a lot that I have to switch to another app mid semester.

The only other app that integrates PDF annotation similar to Logseq is RemNote, but the community there is much less active, resulting in noobs like me have unanswered questions whether it’s in Discord or Discourse. And I’ve heard that its performance is better than LogSeq, but also not that much better either and there can be some serious issues as well.

I used to manage my PDFs in DT, and link to Obsidian. The Logseq workflow is great, thought needs some polishing. I like the task management as well. The app has huge potential which is why I came on board. I really hope that the speed issue can be fixed.

Tried refreshing, reindexing as well as reinstalling :man_shrugging:

Here’s a screen capture of the lag

Loving logseq on mac and I think it’s far better designed than obsidian (eg block-level organisation, task handling, pdf, date handling). However there seem to be considerable lags on my Windows work machine. Switching to the online version may help, but it lacks a plugin architecture.

If my notes folder is on iCloud, can I open it in the online version?

The online version works on local files. If you’re using iCloud as backup, but files are local, it should work. But I think, most reported lags are with Windows.

While some instances of lag may be due to the size of the graph (or the page at hand), there’s a bug that seems to affect even small (brand new) graphs. As Hulk above alluded to, it seems to only be an issue with certain Windows environments.

The devs are looking at it and I am hopeful for a resolution - I, too, would love to use some plugins. However, for now, the web app is working fine for me.

1 Like

Thanks. I’m using a Mac, the issue seems similar though my lag is longer than 1-2 seconds

Did anyone find a resolution to this?

Performance should be significantly improved lately. Do you still have sluggish performance? Please upgrade to 0.7.5 and see if it helps.

For anyone still experiencing this, I did end up tracing down my issue.

This ended up being the “Git” plugin that i was using. By default, the plugin was doing a status check every time the Logseq database was updated. This happens to be pretty much every time you make any change (ie type a character). The author recently added the option to turn this feature off and my speed is back to normal.

I would suggest everyone to check your plugins and possibly temporarily disable them to see if that has an effect.

1 Like

I had this in Windows, but not Mac. My Windows installation has improved significantly with recent updates.