Linux Version of Logseq is slow

Guys, a quick catch up. I think the problem was related to my distro (garuda linux), the hdd or simple the messed up filesystem that I choose to use as my first filesystem. I’ve installed endevouros and arch and everything works fine. Didn’t expect that this topic is still active

as a suggestion, don’t use logseq on garuda linux with butterFS Filesystem

1 Like

Just an observation on Linux LogSeq running slow

i use logseq with : Debian (12) and Plasma - I changed the latency on the compositor to lower latency. Still struggled with the slow performance (key lag etc).

I turned off all the plug ins and performance is back to normal - will do some further investigation on which plugin appears to be producing this behaviour

Thank you for your reply.

I too have done some tinkering. I disabled all the plug-ins and also swapped from X11 to Wayland. Although I prefer X11 because it supports KDocker, Wayland yielded more of a response when typing to the point where the lag is negligible.

Logseq still takes a minute of so to load, but I do have over 2,500 pages(?) to load and index, so I happy to set it off in the morning and go and make a cup of tea.


thanks - i think i need to gather some telemetry on why logseq goes slow - my instinct was a plug in was delaying it - but it appears to still be occurring (i will post further findings)