Logbook quick question

How can I force Logseq to recalculate the time difference between two data points when manually adjusting an incorrect :LOGBOOK: entry?

    - DONE Sleep
      background-color:: black
      CLOCK: [2024-06-20 Thu 23:59:00]--[2024-06-21 Fri 11:00:01]

Logseq insists that the time difference here is 59s … ??? It should be about 11 hours.

Logbook should look like:

  CLOCK: [2023-01-16 Mon 19:41:41]--[2023-01-16 Mon 19:41:44] =>  00:00:03
  CLOCK: [2023-01-16 Mon 19:41:54]--[2023-01-16 Mon 19:44:42] =>  00:02:48

Where the => points to the time interval.
Unless they recently changed that. I haven’t been using time tracking recently.

1 Like

Oh hi @Siferiax, it’s you.

What I am trying to do is a bit messy, but not completely dysfunctional. Here is what I do know for a fact:

:with-second-support? true; default false; limit logbook to minutes, seconds will be eliminated
:enabled-in-all-blocks false; display logbook in all blocks after marked with now or doing
:enabled-in-timestamped-blocks true;
:feature/enable-block-timestamps? true

My vanilla Desktop Logseq is set up to calculate the time interval, but the unit is always s which is mostly wrong. Does Mobile behave any less unintuitively?

This is my child’s computer so I will try to capture what is being done wrong:

This is solved now, thank you.

Two little “tricks” I have learned is that you can highlight time without extra CSS or plugins with vanilla Desktop by using triangular brackets. The EBNF would be “<” int “:” int “>” or something to that effect, for example <07:30>

The other is if you can’t remember the start/end time of a block, but know you spent about 7.5minutes, just cheat and add

- DONE Notepad and seqlogbook.gif
  CLOCK: 7:30


But I do not recommend it. My Logseq has crashed several times today.