Logseq 0.10.3 fails to run and/or reinstall [please help me debug this]

I restarted my Win10 system just now and Logseq fails to run. I suspected it is due to the 0.10.3 update two days ago and confirmed this by installing and running 0.10.2 without any trouble

The log that pops up holds no entries pertaining to Logseq
Some fist and last entries from the log that pops up:

  • First entry = 7684> 2021-06-25 16:41:02> Program: Starting install, writing to C:\Users\Rikus\AppData\Local\SquirrelTemp
  • Last entry in log = 2023-07-29 02:17:09> ApplyReleasesImpl: Updating shortcut C:\Users\Rikus\Desktop\Discord.lnk

There was an issue with Windows’s native anti-virus service, which solved the problem.

tl;dr where does Logseq store its running log files?

I have unticked solved because two weeks later the same weird bug is back again. It seems to happen after a Win10 update. Since this isn’t an emergency I would like to see if I can solve it myself. Where does Logseq store its logs? I do not know much about electron apps. I have already checked the Squirrel installer logs and there is no problem there.

There is none that I can see in the .Logseq directory, nor in the local %appdata% directory. The roaming directory has a bunch of weird pointers in it.

Maybe one of these:

  • C:\Users\Rikus\AppData\Local\Logseq\Squirrel-Shortcut.log
  • C:\Users\Rikus\AppData\Local\Logseq\app-0.10.3\Squirrel-UpdateSelf.log
  • C:\Users\Rikus\AppData\Local\SquirrelTemp\Squirrel-Install.log
  • C:\Users\Rikus\AppData\Roaming\Logseq\logs\main.log
1 Like

Thank you. Marking this as solved because the problem appears more and more to be with my setup rather than Logseq.