LogSeq is almost great

I think LogSeq should have a price, so the development team will better the tool.

It has great potential (comparing to all the other outliners I’ve tried), but it still lack fundamentals.

  1. I can’t filter tags in a pge
  2. I can’t right-click on a reference to (swap/embed,etc)
  3. There’s no good sync solution (currently using Syncthing, best I’ve found, but we’re always having conflict problems)

and worst of all 4) LOGSEQ IS ALWAYS CRASHING in my mac.

It not actually crashes, but it freezes and I can’t do anything. Can’t even click, and have to restart it (which take some minutes).

This happens twice every hour, and it’s driving me crazy : (

Oh and how could I forget 5) DATA LOSS

Sometimes suddenly something I wrote is gone.

Thankfully when I look into the .md file, the content is there, but why it’s not on LogSeq?!

Anyway, this is my feedback and those are the bug/lack of features that would make logseq 10x better if eliminated.

Don’t get me wrong, I LOVE LogSeq (were on roam for 2 year before, I’m on LogSeq for ~8 months now).

And because I love it, I want it to be better.

Most tickets I’ve found on this forum were not answered, and most feature requests were not delivered.

And I know the team behind LogSeq does not like this too.

So please, start charging so LogSeq can have the team it deserves and have those problems (especially crashing & data loss which are emergencies) fixed.

Thank you!

1 Like

Logseq will soon launch a pro service with encrypted sync capabilities. Which should alleviate the third concern you mentioned.

With regards to filters, have you tried clicking the filter button next to the linked references?

And with regards to the swapping and embeddding, have you considered the Swap Block plugin?

Also right clicking a block reference should give you the option to turn it into an embed.

And with regards to freezing, have you tried turning off all plugins and seeing if it’s better? That could be one of the chases.

Any way that some of your issues are system/user specific? I haven’t experienced any of these issues.