Logseq namespace hierarchy not showing up in parent page

EDIT ** Also posted on Github here : Namespace hierarchy not showing up in parent page · Issue #6547 · logseq/logseq · GitHub

So I’m coming across a bug with namespaces: when creating a simple page 1 / page 2 setup, the following weird behavior happens :

  1. hierarchy shows in page 2, but not in page 1.
  2. if I create page 1 before page 1 / page 2, there is a duplicate in the “all pages” view (even though it’s the same page when I click on it).

Some images for reference:

Example of page 1 / page 2 (hierarchy shows)

Example of page 1 (no hierarchy visible)

All pages view show duplicates for page 1 examples (I created them before creating page 2):

I tried, but without any success:

  • Refreshing
  • Re-indexing
  • Deactivating all plugins
  • Deactivating themes (going back to default theme)
  • Reinstalling Logseq (currently running v. 0.8.3)

Thanks for your help!

Francesco.

The problem was the spaces around the backslash. Without spaces everything works.

2 Likes

In case someone is in the same situation as me:
I’m currently having the same problem, even if between the slashes there are no spaces. Luckily, after looking up on GitHub, it’s been solved already on the new nightly release. For further information: name hierarchy is invisible · Issue #7590 · logseq/logseq · GitHub

1 Like