Logseq not installing on Latest Windows

I have downloaded a fresh install of Logseq and tried to install it on my Windows Laptop. But running the .exe does nothing.
I switched off the Windows Security but not difference.
I downloaded the version 9.9 but not difference.
I tried to using the “run with administrator” but no change.
I have tried all of the above with version 10.6 / 10.5 and version 9.9. but logseq wont run on windows.
Just to check if windows is blocking such installation, I ran krita and riot. both ran fine but not logseq.

Please advice and let me know know what is happening? Thanks in adavance.

I am using Zettlr but now would like try out your amazing Logseq.

Are you getting an error of some sort, by any chance? I have noticed some weird things happening with cross-platform applications in particular on windows these days.

No error. just as though it is not even a file. Nothing opens. I even checked the Task Manager to see if Logseq war running in the bacground. Nothing

I have the same problem

My problem was resolved finally with the help of discord server of Logseq, it turned out to be Windows blocking it, had to unblock that was on properties of the execution file,