Logseq Quick Capture on Linux (Appimage)

Hi everybody,

I just installed and tried to use this chrome extension that should allow me to do a quick capture of the web-page that you are currently at and send it immediately to my open Logseq graph:

Sadly, it doesn’t work for me. I see from the reviews (some also very recent, from a few days ago) that it works for most users.

I also tried this workaround, that sadly doesn’t work for me either (but seems to work for most people):

Changing browser (Chrome, Chromium, Firefox, Brave) didn’t change the outcome.

Then I remembered that I have an annoying issue to login to Logseq sync due to the fact that I’m using it from the Appimage on Debian, and the intended workflow from the browser couldn’t really access to the application. I guess this could be a similar issue.

The fix for the login issue was quite complex, but at least one-off…I’m skeptical there may be a one-off fix to this…but maybe?

Does anyone have some suggestion?


I am the author of the plugin. Do you mind filing an issue on GitHub and provide more info as to what you observe?

Edit: Ok I read your post in further detail. You need to be able to associate the opening of Logseq links with Logseq on Linux.

1 Like

Thank you, you are right, it’s a more general problem with any kind of Logseq-link.

Sorry for misattributing it to the specific plugin: I just didn’t notice it until I tried to use your plugin (great one btw, thanks for your work!).

May I ask if somebody has a link to an up-to-date fix to links on Debian? I followed a bit this issue and its link but I’m a bit confused about the state-of-the-art-fix:

You have tried this fix?

Yes I’ve tried, gathering info from that thread and other threads linked there:

  1. I created a ~/.local/share/applications/Logseq.desktop file (there wasn’t one)
  2. I filled it with this (with [path] equal to my Appimage file path and name):

[Desktop Entry]
Exec=[path].AppImage %u
Comment=A privacy-first, open-source platform for knowledge management and coll>

  1. I executed:

sudo update-desktop-database
xdg-mime default Logseq.desktop x-scheme-handler/logseq

Still nothing. Probably I messed up some passage.

Apologies, then I am really not sure. I am on MacOS and not on Linux. Not really familiar with what must be done to fix this.

1 Like

Thanks all the same!

1 Like

Just to follow up: I’ve solved the issue by re-installing Logseq via this script: Handy shell script to install and update Logseq on Linux · GitHub

I had to install imagemagick before, otherwise it wouldn’t work. After that all worked correctly.