(Mac) Logseq blocks 3p keyboard shortcuts

I use SizeUp (a 3p MacOS app) for window management. SizeUp’s keyboard shortcuts don’t work with Logseq (there’s just a beep) despite not conflicting with any Logseq shortcuts.

I believe this is a bug, as I have used SizeUp for years and it’s worked with every other app. It worked with Logseq as well until very recently.

It works fine with BetterSnapTool (which is also an app for window management), so Logseq can be maneged.

  • Do you have any other electron apps? (Logseq runs inside electron, a chrome-derived wrapper)
  • What keybindings are you using? And do none of the keybindings work?

re: Electron, it works fine with Spotify and Slack

here are all the keybindings I use, they’ve all recently started failing with Logseq:

I set ⌃⌥⌘-C on BetterSnapTool to left upper corner (not very useful, but that one was still free), and it works fine with Logseq (and other apps). No idea how to test this further. As far as I can see, Logseq doesn’t eat the key-binding, and the window responds to moving it about. Does SizeUp have an issues-page? I would try there as well.

Restarting Logseq fixed it.

1 Like