Missing "DOING" todo's from "NOW" section

Hi all, hope you are doing well. I am a new Logseq user since January this year and I have encountered an issue related with “DOING” todos that appear at the bottom of each journal page for the current day.
Yesterday, I had four “DOING” todos but today I have only two of them showing. From the missing ones, one has disappeared entirely (I went through all my journal entries from the beginning) whereas the other appears in the page that lists out all blocks containing that tag. Screenshot of the main page with the two todos under the “NOW” section:

Screenshot of the “DOING” todo that appears in page that corresponds to the tag but not in the “NOW” section of the main page:

Anybody encountered a similar issue and can provide help on fixing this?

Thank you in advance!

Have you tried changing the timespan of the queries at the bottom of the journal home page? I think the default value is two weeks, which is about the time at which your missing task entry was made.

If that is the case, to fix it, open your graph’s custom config.edn from the setting menu (located at ../logseq/config.edn by default). At around line number 222 there should be a query titled “NOW” with :inputs [:14d :today]. Change 14d to what you want the timespan to be.

Also see https://docs.logseq.com/#/page/advanced%20queries/block/relative%20date%20inputs


It worked! All the missing “DOING” to-dos resurfaced:

Thank you so much! :+1:

1 Like