<% today %> won't change


i insert <% today %> in a template,

Screenshot from 2023-12-28 14-15-22

and try to use the template, the date shows up when i click the block,

Screenshot from 2023-12-28 14-17-41

but the date comes back to <% today %> when my mouse is out of the block,

Screenshot from 2023-12-28 14-18-50

is that correct? or how can i render it to a regular date format?

Thank You!

Try to click Enter it should “save” it

1 Like


Thank you for your reply, tried, but didn’t find the Enter.

If insert a space before it, then it changes.

I would like to know how to do it elegant way…


It is bug with cache in Logseq. You need to change the inserted block in order to reset the cache. Add space, comma or any char to any place.

Another way is to use 🏛 Full House Templates plugin:
2023-12-30 04.51.02

Note: I’ve add «+» before template name to turn on template-including-parent mode, which is false by default with the plugin. You can explicitly add template-including-parent:: true property to template itself to avoid this or re-organize template by moving it’s content to child block.

1 Like

hi @stdword ,

this is wonderful, your explanation closed my exploration totally, i installed the plugin and follow your suggestion, it works indeed.

1 Like