Unable to run in Ubuntu when installed with snap

As of today, I am not able to open logseq on Ubuntu when installed with snap. I am getting the following error: 22:22:29.611 › IPC error: {:event #object[Object [object Object]], :args #js ["getLogseqDotDirRoot"]} Error: EACCES: permission denied, mkdir '/home/$USER/.logseq'
I do not have any plugins installed.
Does anyone know how to solve this?
If you need any more information please let me know. Thanks!

Welcome. Based on the error message, have you investigated the permissions in the mentioned folders? (e.g. here)

Ah I didn’t know that there was a snap.

The flatpak works fine for me:

The maintainer has been active in the logseq discord before when I’ve had questions.

The one thing I found was that I needed to add access to /tmp in flatseal when installing plugins - that might be fixed

Hi, thanks for getting back to me.
The permissions on my home directory are normal, I get:

getfacl: Removing leading '/' from absolute path names
# file: home/user/
# owner: user
# group: user

When I run getfacl on my home directory.

Ok, I have changed absolutely no settings at all, neither have I updated any software, and it now partially works. It will run, but it will not remember the folder I had opened. In other words, it used to automatically open the folder I previously had open, but now it does not, and asks me every time. I would say that the reboot of my machine may have allowed it to run now, but I had previously tried rebooting to no avail. I would also like to note the Appimage seems to work too.