Can Logseq synchronize to PDF annotations done in Zotero PDF reader?

EDIT:
I have now also tried to add highlights directly to the PDF using the application “PDF Expert” on my iPad (these annotations are stored inside the PDF). Unfortunately, Logseq cannot extract these, even though they are (obviously) shown in the Logseq PDF reader.
Note that Zotero does automatically extract these and shows them as “Extracted Annotations”. Something like that would be amazing in Logseq; e.g. automatically extracted annotations could be shown inside the page corresponding to that citation. It even seems preferable to using Zotero annotations, because you can add these annotations from any PDF editor and they are local to the PDF and hence easy to share.
Could something like this be implemented as a plugin?


Dear all,

I am new here and would like to start using Logseq, because its integration with Zotero. Logseq seems like an awesome tool for building knowledge from literature research and I am eager to jump in (kudos to the developers!).

After testing PDF integration with Zotero, I have found that annotations (i.e. text highlights) done in Zotero are not shown in Logseq and vice-versa. Through a bit of research, I have found that annotations in Zotero are not stored in the PDF, but in a separate database (see here). Same seems to be true for Logseq.

So my question is, whether Logseq is able to “pull” annotation from Zotero. This is important to me because I do most of my reading in the Zotero PDF reader, which works nicely on my iPad (also with Pen) and reliably syncs PDFs and annotations to my Desktop through WebDAV.

I have read other forum threads discussing PDF annotation export/integration from Zotero to Logseq (such as this one), but is not clear to me from that, what the status quo is and whether this is doable. I would also be happy with a (scriptable) work-around.

If this is currently not possible, is there something like this being worked on?

Thank you and best regards,
Michael

PS: These are my specs:
Logseq 0.8.7
Zotero 6.0.13
System: Ubuntu 22.04.1 LTS

3 Likes