Zotero 6 Annotations

Hi,
I have been using Zotero 6 for reference management and annotation (since with v6 there is a pdf reader). I use “Add Note from Annotations” in Zotero to create an “Annotations” Note:

image

However when I use “/Zotero” to load the reference and its annotations to Logseq, there are 2 problems:

  1. The links to highlights are lost. (Clicking a highlight doesn’t open up the section in Zotero PDF reader) → workaround: Zotero 6 Annotations - #2 by nottakumasato

  2. All annotations are in the same block so it is impossible to refer to a specific highlight: → workaround: Zotero 6 Annotations - #3 by nottakumasato

  3. Area highlights show up as italic “image” when copy-pasted from annotations note export: → workaround: Zotero 6 Annotations - #4 by nottakumasato
    image

Is there any way to fix these issues? Or any workaround for the time being?

Thanks in advance!

Setup:
OS: Windows 10 Desktop
Zotero: 6.0.10
Logseq: 0.7.8

  1. The links to highlights are lost. (Clicking a highlight doesn’t open up the section in Zotero PDF reader)

I found a workaround for this: Right click on “Annotations” note and click “Export Note…” and save it with Format=Markdown & Options with Include Zotero Links checked. Then if you copy-paste the markdown in the resulting file to logseq, then the zotero links work

All annotations are in the same block so it is impossible to refer to a specific highlight

Workaround for this was to copy-paste the Annotations.md (from Zotero) without the first two lines:

# Annotations  
(7/26/2022, 4:17:43 PM)

which resulted in:

Area highlights show up as italic “image” when copy-pasted from annotations note export:

Workaround for this was to manually use the snipping tool to replicate the area highlight and paste it into logseq and deleting \[image\]:

seems like we need a plugin to automate these formatting tasks and save the notes file directly into logseq’s library

2 Likes