Missing Logseq iCloud folder is not recreated on re-install

Just started trying out Logseq and messed up my graphs on Desktop, iPad and iPhone so I just deleted th Logseq apps, my graphs and fodlers, including the iCloud Logseq folder with the Logseq icon on it. I just expected Logseq to recreate the folder when I reinstalled the app, but that’s not the case.

In the desktop app I get error message like

The directory /Users/mikaelja/Library/Mobile Documents/iCloud~com~logseq~logseq/Documents/Ipadtest has been renamed or deleted, the editor will be disabled for this graph, you can unlink the graph.

and

The graph logseq_local_/Users/mikaelja/Library/Mobile Documents/iCloud~com~logseq~logseq/Documents/Ipadtest can not be read:Error: ENOENT: no such file or directory, scandir /Users/mikaelja/Library/Mobile Documents/iCloud~com~logseq~logseq/Documents/Ipadtest

On my iPad I see things like
file:///private/var/mobile/Library/Mobile%20Documents/com~apple~CloudDocs/7EC2D587-4BA7-4E17-B728-9CE202680BB5/ has been renamed or deleted, the editor will be disabled for this graph, you can unlink the graph.

Is this a known behaviour? Any ideas for how to fix it?

Welcome to Logseq and the community @mikaelja!

This is expected behavior; when you delete a graph, so is its folder deleted. Recreate the folder and graph and you should not see any errors anymore.

Sorry, it’s not working.

I try to create a new graph on my iPad:

  1. Add new graph, enable the iCloud sync and give the graph a name. I don’t get any options to select where to put the graph.
  2. I get the Journal page for today and start writing. I can create new pages and links.
  3. BUT if I switch to another graph, created in the same way moments earlier, I get an empty graph and the error message The directory file:///private/var/mobile/Library/Mobile%20Documents/iCloud~com~logseq~logseq/Documents/iCloud_sync_test has been renamed or deleted, the editor will be disabled for this graph, you can unlink the graph.
  4. I can’t find any of the created files or folders on my iCloud Drive. There is no Logseq folder on iCloud Drive

You really have to store the graph in the folder with the Logseq logo, otherwise the app can’t write anything to disk and you get the errors you mentioned. This is a limitation imposed by Apple.

Try this:

  1. Uninstall Logseq and restart your iOS device.
  2. Install Logseq and restart your iOS device.
  3. Open Logseq, create a new graph and create a folder within the Logseq folder in iCloud (the one with the Logseq logo).

But that’s the problem - the Logseq folder on iCloud Drive is missing (since I deleted it, trying to get a fresh new start). I tried to uninstall Logseq and reinstall again but still no folder with the Logseq logo.

Does restarting your iOS device after the first two steps not result in an iCloud folder with the Logseq logo? From all similar reports I’ve received, that always does the trick.

Well, now I’ve tried again and made sure to restart again after just installing Logseq again. The thing is I don’t get a chance to select where to put the new graph. And even if I would there is still no Logseq folder on iCloud Drive.

Any new graph is apparently created locally in the Logseq folder on my iPad. It’s like of Logseq is unaware of iCloud. Just checked my iCloud settings and Logseq is enabled to use iCloud.

It’s not a common reported issue.
Can you try deleting the Logseq directory from iCloud first (if exists), then re-install Logseq? The directory should be created on app start up

Reference:

That’s exactly what I’ve done:

  1. Uninstalling the Logseq app, on iPad, iPhone and macOS.

  2. delete the Logseq folder on iCloud, using the Files app on iPadOS.

  3. empty the trash on iCloud Drive in the Files app on iPadOS.

  4. Restarted iPad.

  5. Checked the Files app: no Logseq folders left. The trash can is still empty.

  6. Installed Logseq.

  7. Restarted iPad

  8. Checked the Files app: no Logseq folders found. The trash can is still empty.

  9. Started Logseq.

  10. I get the Welcome to Logseq-screen with the options to create a new graph or select an existing graph. I don’t get the welcome screen showing the iCloud Logseq folder and the information about how information is stored. Instead I get this:

  11. Selecting Create a new graph asks for a name and the option “iCloud sync”:

  12. Todays empty Journal I shown and I yot down a sentence.

  13. I choose the left corner menu and select All graphs:

  14. Then I click to open Documents/MyGraph and facing an empty journal page - the text I entered moments ago is gone. And I receive the error messages about missing folders:

  15. Going back to the Files app and checking iCloud Drive - still no Logseq folder.

  • As far as I can see the default folder is not created when Logseq is launched.
  • iCloud is working as usual in all my other apps, including Notes, Obsidian, NotePlan and iA Writer.
  • Logseq is enabled in the iCloud settings.
  • I’m running iPadOS 16.4 (20E246) and Logseq version 0.8.18
1 Like

Too weird. I can’t reproduce the issue following your steps. The Logseq folder always created as expected on my devices.
There might be something blocking the directory to be created. And the logic for creating directory is in the attached codebase above.

I can only reproduce the error you provided via settings<Your name>iCloud → Toggling Logseq to disable. I don’t know if this is what you mentioned as

checked my iCloud settings and Logseq is enabled to use iCloud.

Can you take a screen on it?

Anyway, the issue is Logseq can’t access iCloud by some reason. Maybe it’s an issue of Apple. We can’t reproduce the issue with the provided clues.

I’m having the same exact issue. Running 0.9.1

1 Like

I’m having the exact same issue; on both my iPad and iPhone.

So far I’ve tried everything bar resetting my devices to factory defaults; but no go.

Anyone have any ideas?

Eugéne

Still nothing. I habitually go through the same sequence now once a week but still no joy. I’m starting to think that syncing via iCloud Drive is a purple unicorn. :stuck_out_tongue: