Why auto-close `~`?

The single-tilde wrap, such as ~this isn't strikethrough~, is not recognised in Markdown; what Markdown recognises is the double-tilde wrap, ~~this is strikethrough~~, which Logseq has a shortcut for. So why auto-close ~? It’s not only redundant, it also slows down the writing. I often want to use ~ as a single character, but the app automatically inserts another every time I write one, forcing me to do an extra key to delete it.

Is there a way to disable the auto-close for ~?
(May be related to this request.)

The number of characters when completing doesn’t matter.
for example, think of [ by default, logseq will attempt to close it by adding ]. This is not different from [[. Logseq will close each one separably, resulting in [[]]

In default markdown, [text] does not do anything and is not a valid Markdown syntax. But [text](https://example.com) is a valid syntax in Markdown and [[text]] is a wikilink (not default markdown)

I think there should be an option to disable auto-closing, preferably with granular control to allow users to disable some or all.