Why is a repeating event whose last instance was from a long time ago showing up in my daily schedule?


Below is a screenshot from my daily page (NB countdown info, e.g. “(past 77d)” comes from the wonderful countdown plugin). These are repeating events. They are perpetually generating reminders even though the last instance of the event was a long time ago. Does anyone know how to prevent this behaviour?

NB AFAIK these reminders are included by default in journal pages, but they don’t seem to be specified in the config.edn file.

They show up because they are scheduled in the past.
The date they are scheduled on was yesterday and 26th of June.
This is for when tasks should be executed. (normally their use case anyway, idk yours)
When a task is set to DONE, it will repeat the schedule based on the scheduled date set (in your case the scheduled date would change to next year)

Having said that, here’s the related config information to search for:

 ;; Disable the journal's built-in 'Scheduled tasks and deadlines' query.
 ;; Default value: false
 ;; :feature/disable-scheduled-and-deadline-query? true
 ;; Specify the number of days displayed in the future for
 ;; the 'scheduled tasks and deadlines' query.
 ;; Example usage:
 ;; Display all scheduled and deadline blocks for the next 14 days:
 ;; :scheduled/future-days 14
 ;; Default value: 7
 ;; :scheduled/future-days 7

You can remove the ;; to activate a line which starts with :.
For example :feature/disable-scheduled-and-deadline-query? true

Thanks for this, and for pointing out the relevant parts of the config.edn file. However, I am still confused. These are not tasks. These are repeating / scheduled events. For the second event, its last instance was a long time ago, but it is still showing on my daily journal page.

NB I am also not sure why these are showing up at all. I have a default template for my journal pages. It does not specify that scheduled / deadline events be shown. Moreover, my config.edn file does not specify that any scheduled / deadline events be shown. It’s a complete mystery to me why these repeated scheduled events are showing (NB I am quite happy if Logseq adds scheduled / deadline events for the current day, and actually find this quite useful, but the current behaviour is frustrating).

Whether they are tasks or not is in this case irrelevant.
What you are seeing is the default scheduled / deadline query as seen in the config info. You can disable it to have these no longer show up.
Unfortunately I don’t know what query logic it uses.
What I think it does is get all block with a scheduled or deadline date of which the date is no more than number of days in the future (per config setting).
Your blocks are returned for this statement.

I would be interested in your use case from using the scheduled date for these events.
If you expect to see these events again in a year time, then I will have to disappoint you. This is not how that works, as I sort of pointed out in my previous comment. The repeating aspect works with tasks.

If it is only to log this event happened on this day then having it on that journal day would be sufficient.

But of course I don’t know your consideration when choosing this approach.

Thanks for pointing out the issues with repeating scheduled events. I have removed the repeat, and these disappear from my Journal Page, which solves the problem. I think a more sophisticated system would be for Logseq to base inclusion in the Journal Page on the NEXT instances of a repeated scheduled event, but it clearly does not work that way, and I am not sure this would be a high priority alteration.

Or, I could possibly turn these into tasks…

I think you misunderstand how it works?
The scheduled date for your events is in this year. There is no instance, there is only the block with the information.
There will be no next instance of those events.
If you make them a task and then click them done, they will be changed to a scheduled date of next year, there will not be a new instance.

See also the discussion I had with someone here:

1 Like