Custom page name for a Zotero citation

After inserting a Zotero citation through /Zotero command, the citation (hence the name of the corresponding Page) reads like @possibly_very_long_title_of_the_paper. It would be nice to be able to change this default citation format. Say, [author, year] or something like that.

I am aware of the short discussion at Allow for Citekey in Zotero note filename (customisable names for Zotero filenames). But the solution shown there does not work for me and the discussion is closed now.

I do have Better Bibtex fo Zotero installed and configured. Citation keys are now generated for all stored publications in Zotero. I also did set the extensions.zotero.translators.better-bibtex.autoPinDelay to 1 in Zotero settings.
I also manually “Pin(ned) the Bibtex key” for a selected publication. And no change is visible after inserting the selected citation in Logseq.

Has anyone succeeded in configuring the “citation style”?

1 Like

I do not know what has changed (maybe I have just restarted this or that) but somehow it works now.

It appears that it is crucial to pin the bibtex key to the selected publication.

I await the holy grail of styled citation document exports from Logseq - that I might click export, choose Chicago style, and have the document come out with all bibtex keys translated into correct formats with a bibliography at the end.

Great to know that it works for you - so this means that citations keys are resolved to read [author, year] in your logseq pages and graph? Cold you add a quick walk through how you achieved this, maybe even with a screenshot or two? In addition it would be great to know which release versions of the involved tools you are using. This would be extremely helpful for those of us who don’t get it to work (yet!)…but even a few lines of info would help, thanks in advance!

For anyone else following, the solution is (mysteriously) as noted here:

In zotero if you have the BetterBibTex extension, right click the citation, select BetterBibTex, then Pin BibTex key. Like the OP, I don’t know why this works, but it works now. Yay! (?)

1 Like

Indeed, this is what I did (BetterBibtex pinning). Without any additional (re)formatting, using just the default setting of BetterBibtex, what I get in my Logseq is then something like

Introduced in [[@nocedalNumericalOptimization2006]], section 12.5, page 330.

Sorry guys I did not reply earlier. With the default setting here at this discussion forum I did not receive notifications that my contribution has been responded to.

1 Like

I would like to second this and mention that with the default setting the citation format does not change while the citation keys are pinned!